Upgrading to sbaz >= 1.10

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Upgrading to sbaz >= 1.10

Lex Spoon
If you have the Scala Bazaar tool, sbaz, installed on your machine,
then your next upgrade needs to be done carefully.  The ritual is:

        sbaz update
        sbaz install sbaz/1.9
        sbaz install sbaz


In more detail, the issue is that a forthcoming change in the Scala
library is binary incompatible.  Future versions of sbaz's own sbaz
package are going to use their own copy of the library binary, to
avoid this problem.  The first upgrade, however, needs to be done
carefully.



Alternatively, you can (re)start from a fresh bootstrap file for sbaz,
in which case you'll already have version 1.10 or newer properly
installed.


-Lex